memcached

pecl install memcached

PHP extension for interfacing with memcached via libmemcached library

This extension uses libmemcached library to provide API for communicating with memcached servers.

Version 0.2.0 change log


- Refactor the way payload types are stored in memcached flags to optimize the structure
and allow for future expansion. WARNING! You have to flush the cache when upgrading from
an older version.
- Add JSON serializer support, requires PHP 5.2.10+.
- Add HAVE_JSON and HAVE_IGBINARY class constants that indicate whether the respective
serializers are available.
- Add 'flags' parameter to getMulti() and getMultiByKey().
- Add GET_PRESERVE_ORDER class constant that can be used with abovementioned flags
parameter to make the order of the keys in the response match the request.
- Fix an issue with retrieving 0-length payloads (FALSE boolean value).
- Add several tests.

Maintainer

  • Andrei Zmievski (lead )
  • Mikko Koppanen (lead )
  • Aaron Stone (lead )
  • Remi Collet (lead )
  • Aaron Stone (lead )

Details

Categories

Stars: 983
Issue openned: 50
Downloads: 16843002
0.2.0
15 years ago

requires:

  • php >=5.2.0<=6.0.0
  • pearinstaller >=1.4.0b1
Request a build
Request to the website owner's team the built this extension with this parameters. The result is not guaranteed and can be impossible for many reasons. The extension source code is frequently not upto date with the most recent PHP version.
If you have another code source for this extension, provide it in comment.
Please (or register) to request a build.